In review

First letter of word ignored when autocorrecting or swipe-deleting

On an iPhone, load any website in the Chrome browser (other places on iOS too I'm pretty sure, this is just a consistent repro). Tap the address bar at the top to select the url you loaded. Type the word 'season' and press space. 'season' autocorrects to 'sWatson' or 'sreason'. The first letter isn't changed and the rest autocorrects as though the first letter wasn't there (including capitalizing names like Watson). This happens for any word (e.g. 'hello' changes to 'hwool' or 'helk o' because 'wool' and 'elk; are words and 'ello' isn't).

More consistent repro steps not involving autocorrect: swiping to delete the word also ignores the first letter of the word. Tap to select the address bar in chrome, type 'hello' and swipe left to delete the word. Only the 'ello' is deleted, leaving an 'h'.

This bug seems to only occur in textboxes whose entire value is selected by the app (e.g. when tapping an existing url in the address bar, chrome autoselects the field). If the blue handles appear (the ones you use to select the text), the bug does not manifest.

This happens to me often enough that I was compelled to file a bug report. Most often in the Chrome address bar because it has the select-all-on-tap behavior.

-1

Comments

9 comments
  • Hi Mike,

    Thank you for sharing this bug find with us! Sorry for the inconvenience it's been causing you. I have created a ticket with your report so our dev team can review it and prioritize it. 

    Let us know if you notice this behavior in other locations/Apps besides Chrome. 

    Thanks again,

    -John

     

  • The iOS Safari browser also selects the url when the address bar is tapped, but isn't experiencing this bug. Chrome may be the only app exhibiting this. I remember it happening all the time before I spent some time finding a consistent repro, but it may have all been when typing a search term in the Address Bar.

    Fleksy is the only keyboard that messes up. I've tried a fresh install of Fleksy on a friend's iPhone 8. It does the same thing. Are you able to reproduce on your end?

  • That's right with the Chrome. This also happens to me all the time. As soon as I start writing a search term with s, Google immediately automatically inserts my blog address, which also starts with s, into the browser address bar. And when I swipe left on the keyboard to delete, a swipe always deletes the entire address except for the s I wrote myself at the beginning

  • But I find this smart and good, because I wanted and want to write a word with s.

  • But the address bar is also used for entering search terms, which I do just as often as entering a url. If your search involves multiple search terms, after you press space after the first word, it's auto-corrected into something obviously wrong, like sWatson.

    Also if you make a typo in the first search term, it's autocorrected into something wrong because it didn't consider the first letter. My workaround is to write a word, press space and if it was autocorrected incorrectly, swipe left to delete everything but the first letter, then swipe left again to delete that letter and try again being very careful to get every letter correct. Fleksy's best time-saving feature, it's amazing autocorrect, backfires in Chrome's address bar and typing ends up taking longer than if autocorrect wasn't enabled at all.

  • The bug happens even when Chrome doesn't insert a suggestion while typing. The following two screenshots show what I mean. The second is after typing a space after typing eyeball. Notice in the second screenshots that Fleksy's suggested words also ignore the 'e'.

  • I just tested by typing #eyeball # into the Chrome search. With the language setting German, it was changed to #Eye ball #. And then I tried it again with language setting English and then the word #eyeball # was accepted with the space. I also took a picture of it. Did you maybe also make English input without an English keyboard like me first? The official Fleksy country dictionaries know only their language. 

     

    Unfortunately, the curser is somehow not visible on the screenshot, but the space key was clicked and the word was preserved

     

  • Sometimes the bug doesn't happen. It consistently happens if you follow the repro steps in my first post, though, killing chrome, relaunching, waiting for it to load the website that was there when you killed it, tapping the address bar, typing 'eyeball', pressing space. Does it happen when you follow those steps exactly?

  • Ich habe meinen Chrome-Browser geschlossen und es dann so gemacht, wie Sie es angegeben haben. Ich habe das Wort oben in die Suchleiste der letzten geöffneten Seite eingegeben. Meine letzte Seite war das Fleksy Forum hier und genau diese Beitragsseite hier von Ihnen. Und das kam heraus, bei mir hat es einfach funktioniert. Aber ich glaube dir, dass es manchmal nicht funktioniert. Und dann hoffe ich, dass Fleksy das Problem lösen kann. 

     

Please sign in to leave a comment.

Didn't find what you were looking for?

New post